[self-interest] Corrupted download 4.1.1 for Mac?

Ashley Ward ashley at dcs.warwick.ac.uk
Thu Jan 13 01:50:48 UTC 2000


I've been trying to download Self for our new iMac DV (400MHz).  I've
tried twice now, but with no success - a little fustrating as the
download takes over an hour.  I can decode the .sea.bin file (both
times I've tried the MacBinary version) into a .sea file, but then
running the .sea file produces an "error -39".  Turning the virus
checker (Norton) off changes the error message produced to a "corrupted
application" or similar message.  Dragging the application to various
decoders (StuffIt Expander 4.0.2 is the most recent I've tried, I
think) gives various messages: some mention corrupted files, some are
silent but do nothing.

I thought this might be Internet Exploder making a mess somehow, but
I've tried a similar process on UNIX - download either file using lynx,
then use "mcvert" or even "macunpack" and I get a message such as:

  ashley at topaz 52 /var/tmp/Ash > mcvert Using_Self_mac.sea.bin

  Input file     Using_Self_mac.sea.bin     
  Warning: skipping legal but suspect line in hqx file -- line too
short (1 < 12)
  Premature EOF while reading BinHex 4.0 Using_Self_mac.sea.bin

  last perror (may not be relevant): Error 0
  mcvert: exiting

This suggests to me that the file on the site may be corrupt, perhaps
truncated?  If I download the .hqx version instead (on UNIX), I can
decode that, but then I end up with a .sea.bin file and the same
problem above again.

Can someone help?  It would be really great to get this working. 
However, I'm not really a Mac file formats expert...

Many thanks...

Ash (currently at home with his new iMac :)

         Ashley Ward - Graduate Teaching Assistant - PhD year 2
    ashley at dcs.warwick.ac.uk - http://www.dcs.warwick.ac.uk/~ashley/
Room 102, Department of Computer Science, University of Warwick,

More information about the Self-interest mailing list