[Self-interest] VM error

Jecel Assumpcao Jr jecel at merlintec.com
Tue May 11 09:51:43 UTC 2021

Maha Alvi wrote on Sat, 08 May 2021 02:52:54 +0000
> I turned off swap and took out 12GB, leaving 4GB, the minimum
> I can have in my system, but still getting the same message.

Too bad it didn't help. I have just tried Self-Release-2017.1 on this 64
bit Ubuntu 18.04 machine with 32GB of RAM and it ran just fine. The last
time I had tried it was on a 32 bit Linux so I wanted to be sure that
this wasn't the problem.

I'll download the latest version tomorrow to see if that makes a

> I don't see any .snapshot files, but there are three .snap files:
> core.snap
> kitchensink.snap
> morphic.snap

Right, those are the 3 image files you can use. Note that you can run
the Self virtual machine all by itself and you will get a text prompt
with an "empty world" that doesn't do much but is fully functional.
Doing something like "./Self -s morphic.snap" will bring up the
graphical user interface (unless the VM itself doesn't work).

core.snap is the smallest of the three image files and includes just
enough for the GUI to work.

morphic.snap includes everything in core.snap plus a wider selection of
graphical objects (morphs).

kitchensink.snap includes everything in morphic.snap plus some complete
applications like a very old web browser and a Smalltalk-80
compatibility layer.

-- Jecel

More information about the Self-interest mailing list