[self-interest] Self on OS X 10.8

Tobias Pape Das.Linux at gmx.de
Sat Sep 21 13:05:34 UTC 2013

Am 21.09.2013 um 13:58 schrieb Chris Double <chris.double at double.co.nz>:

> I tried the Self download for OS X on selflanguage.org but hit some
> problems and am wondering if I'm doing something wrong.
> The download page [1] mentions a 'Self' script being installed in
> /usr/bin but I don't see it after installing. I also needed to download
> and install XQuartz as OS X 10.8 doesn't include the X11 app.
> Once XQuartz was installed the Self snapshot ran. Love the look and the
> fonts compared to the Linux version! The two finger scrolling on the
> trackpad for vertically and horizontally scrolling the world is also
> fantastic.
> I tried dragging a label morph from the morph factory to the main self
> window and I couldn't drag it outside the bounds of the morph factory
> window. Is this broken in the latest version?

I think it is an multiple-X-windows problem.
If you just pick a morph up and select another window, you
have the morph nevertheless. It impedes the usability, but I know
no way around (except not using X on OS X)


-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/x-ygp-stripped
Size: 213 bytes
Desc: Message signed with OpenPGP using GPGMail
URL: <http://lists.selflanguage.org/pipermail/self-interest/attachments/20130921/d264cb2b/attachment.bin>

More information about the Self-interest mailing list