Compiling intel-self on mac

jondraschek at
Sat Oct 7 11:16:11 UTC 2006


I tried to compile the VM on Darwin i386, but I got this error after compiling it strictly 
following your instructions (after adding the header paths for X11, it worked smoothly)

[Session started at 2006-10-06 18:43:07 +0200.]
Self VM fatal error (/Users/niko/self/vm/mac_osx/vm_project/../../src/any/lookup/
sendDesc.cpp, line 457): first_sendDesc() has wrong lookup type

the debugger wouldn't tell me what the lookup type is, but I could fix the code to print it 
to stdout, if that was necessary.


I've sent this mail before, only that it seemed to not have arrived. Well, since then I played 
a bit more with the compliation settings to see what I can do, and I found out a couple of 
interesting things, among which the precompiler line GCC3=1, which I found remarkable, 
because the gcc3 for intel macs does only prodce output for ppc.

So, Self is meant to compiled with gcc4.0.1, right? Does it even make a difference?

More information about the Self-interest mailing list