[self-interest] xcode problems installing Klein

Jecel Assumpcao Jr jecel at merlintec.com
Tue Oct 3 16:37:27 UTC 2006

Chandrasekhar Ramakrishnan wrote:
> > I thought you guys might have been using Xcode 3.0 already - I doubt
> > there would be any real difference between 2.0 and 2.3. My problem was
> > very likely to have been in the uncompression stage.
> There is a difference. Xcode 2.0 uses the .xcode extension / bundle
> format and Xcode 2.2 switched to the .xcodeproj extension / bundle
> format.

Thanks for the tip! This made me think that perhaps the bundle thing is
stored in the same database that associates file types with
applications, so I just tried renaming the folder and though Mac OS X
wasn't too happy about letting me do that the result was that the folder
was automatically transformed into what looks like a file. Clicking on
that calls Xcode which complains that this was created in a newer
version, Making it open this anyway caused a few errors but otherwise
worked ok.

It turns out that the error I got when loading Klein happens even if the
debug server is running. Something about "no 'sourceHand' in nil" with a
long stack trace and finally a primitive failure where _SetTimer (or
similar - sorry that I didn't make a copy of the error log) got a large
integer as an argument. Just typing "prompt start" was enough to have
the GUI running again, and I was able to build a complete image and run

-- Jecel

More information about the Self-interest mailing list