[self-interest] Re: Trouble running Self/x86

Jecel Assumpcao Jr jecel at merlintec.com
Tue Apr 15 00:00:34 UTC 2003

On Monday 14 April 2003 17:32, Paul Chapman wrote:
> I've just redownloaded everything, and used Unix tools  (gunzip, tar)
> under Cygwin exclusively to unpack the files, just to be sure WinZip
> wasn't screwing with them.

I haven't tried Self on Windows myself, but did use an older version of 
Cygwin to get Little Smalltalk and GNU Smalltalk to run in Windows. It 
wasn't too easy to get all the details right.

The Mac version of Self is also a bit complicated to set up. The Sparc 
and the Linux versions are the easiest - just download and go.

What is the "-c" option? The versions I use don't have that.

> Same error message on both Demo.snap and Empty.snap.

What happens if you run Self without any snapshot at all? Do you get to 
the VM# prompt ok?

> Had a bad few days all round: trying to find an incremental, OO,
> platform-independent (or at least multi-platform) environment for a
> project.  Talks2 looked good but is flakey and incomplete.  DSelf
> same.  No luck with Sun's Self, as you can see.  Thinking of having
> another look at Squeak, but last time I was overwhelmed by its
> features and had trouble finding how to do the simple stuff. :)

Io (http://www.iolanguage.com/) is a good scripting level language, more 
like GNU Smalltalk than Squeak or Self (for now, at least).

I hope that someone figures out your problem so you can try Self - it is 
certainly worth looking into even if you then decide to use something 

-- Jecel

More information about the Self-interest mailing list