[self-interest] process (was: selfUnit)

Thorsten Dittmar thorsten.dittmar at daedalos.com
Wed Jun 19 05:35:54 UTC 2002

> On Sunday 16 June 2002 04:39, Thorsten Dittmar wrote:
>> On 6/13/02 11:55 PM, "Jecel Assumpcao Jr" <jecel at merlintec.com> wrote:
>> > [make new process prototype]
>> This way does not work at all. Try it out, make a unchanged new
>> prototype of process.
> I tried it in Self 4.1.5 in Sparc and it seemed to work, so I tried it
> again in 4.1.2alpha in Linux and again got the expected results. Note
> that I wouldn't have been surprised if the VM had crashed as I had
> never actually tried it before.
> I started out by adding this slots to 'globals':
>             selfUnitProcess = process _Clone
> I decided to use the raw primitive instead of risking any of the 'copy'
>  method variations and that might have made a difference.

With _Clone it works also at my machine. Thanks for the hint.I checked the
copy methods from process (and above), I don't find the reason for that
behavior. How ever it works and that is enough for now.

More information about the Self-interest mailing list