Hi Hernan,

The '' character is unfortunately outside the scope of 4.4 - we need a proper unicode/m17n system and a corresponding rewrite of the Self parser.   It's important, but will have to wait :)

Hopefully the fix I've made will handle the numlock issue - the system was incorrectly treating it as the command key.

Try   http://selflanguage.org/files/releases/4.4/beta7/Clean-4.4.beta7.snap 

Almost there!

Russell



On 29/06/2010, at 4:51 AM, Hernan Wilkinson wrote:

 

Hi Rusell, it looks like it is working fine but when the num pad is activated... if it is activated, no number appears even if I use the normal number keys. Also, the does not appear no matter if the num pad is activated, but those are things that can be avoided. It is working better!

 Hernan.

On Mon, Jun 28, 2010 at 3:38 PM, Hernan Wilkinson <hernan.wilkinson@gmail.com> wrote:
Hi Rusell,
 I think the link is not correct, it should be: http://selflanguage.org/files/releases/4.4/beta6/Clean-4.4.beta6.snap

downloading it now...


On Sun, Jun 27, 2010 at 10:26 PM, Russell Allen <mail@russell-allen.com> wrote:
 

Hi guys,


I was submerged by work for a bit there but have crawled out and made another attempt at fixing the Linux keyboard issue.

This time, the code correctly uses X keysym values to determine arrow key presses etc.

Can the Linux people try:

http://selflanguage.org/files/releases/4.4/beta4/Clean-4.4.beta6.snap 

and let me know if it works for them.

Keys should type their correct character, and the cursor keys should work.

Cheers, 

Russell